Enabling SSL on Webmin and CentOS

Quags

Administrator
Staff member
If you have installed Webmin by default SSL will not be enabled. To enable it follow these steps as root in SSH:


yum -y install perl-Net-SSLeay

Edit the file /etc/webmin/miniserv.conf

change ssl=0 to ssl=1

Save the file and restart webmin with

/etc/init.d/webmin restart

Now access https://YourIP:10000/ for a secure connection.
 

KevinB

New Member
You will also need to import the self-signed SSL cert into your browser. Or you can also create a new /etc/webmin/miniserv.pem containing your private key for your domain and your domains SSL cert to use your own domain cert, like this:
-----BEGIN RSA PRIVATE KEY-----
(Contents of private key)
-----END RSA PRIVATE KEY-----
-----BEGIN CERTIFICATE-----
(Contents of SSL certificate: your_domain_name.crt)
-----END CERTIFICATE-----
Then add the following line to the end of your miniserv.conf to reference your intermediate cert file:

/etc/webmin/alphassl_intermediate.crt (just an example, use your own intermediate cert from your SSL provider)

You way also want to go into your webmin config and select the "yes" checkbox for the "Redirect non-SSL requests to SSL mode?" option.
Kevin
 
Top