Free server migration and php/mysql versions

Terri Z

New Member
I have VPS hosting with Cpanel. However I'm on old versions of php (5.2.9) and mysql (5.1.73-cll) because of a few legacy programs. I plan to replace/update those programs within a few months - should I wait until that is complete? Or can I run those old versions of php/mysql on your server?
 

Quags

Administrator
Staff member
If you have cpanel, and are going to a vps with interserver - or considering it - then a KVM vps with cloudlinux is your best choice.

Cloudlinux has many benefits, too many to go into here, but also a higher cost. It runs $10 / month. In addition to adding security you also get php selector. This means you can choose php 5.2 on a website while actually running a higher version of php. So, each user could downgrade their php version if needed. Essentially a single cpanel user can run between php 5.1 - 5.6.

MySQL - I see no reason you would have issues running 5.5 immediately on a new server.
 

Terri Z

New Member
[edited after consultation with my tech team]

Thanks Quags! After consulting with my tech team, I'm a single-user so I really don't need cloudlinux. The kvm they had already recommended.

So - they asked me to ask you if you would be "able to relocate your current environment of WHM version 11.48 running Apache 2.2.29 and PHP 5.2.9."
and would that be possible with your free server to server migration?
 
Last edited:

Quags

Administrator
Staff member
Can you double check on that 5.2.9?

Using a not recommended apache addon to easyapache, I could get to 5.2.17. Could that work?
 

Terri Z

New Member
Thanks for the research, Quags. A not-recommended addon makes me kinda nervous! :)

I'm thinking I need to wait until I can get off those legacy programs. I can tough it out with my current host for a few more months ;)

Thank you - this is all helpful and also gives me a good feeling about your customer support :)
 
Top