Google keeps throttling me for "spam"

Jon W

New Member
I have a virtual server here, trying to move away from a previous shared-hosting setup.
I have a few vanity domain names for me and my family. I am setting up a mail relay with catch-all forwards. Some of the family uses gmail; other of the family uses other ISPs.

I'm using Postfix as the server, and it's configured with SpamHaus block lists.
The vanity domains have proper SPF records for the interserver host.
I'm using SpamAssassin, using auto-updated rules, as well as a few custom rules to cut down a few addresses that get extra helpings of spam. I've also set the spam score threshold to a more aggressive 4.0 instead of the default 5.0.

I'm pretty sure the postfix is not running an open relay.

Yet, Google keeps rate-limiting my sender, with a 421-4.2.7 error:

Mar 20 12:30:53 is postfix/smtp[32124]: BD8A2183880B8: host[] said: 421-4.7.0 [ 15] Our system has detected an unusual rate of 421-4.7.0 unsolicited mail originating from your IP address. To protect our 421-4.7.0 users from spam, mail sent from your IP address has been temporarily 421-4.7.0 rate limited. Please visit 421-4.7.0 to review our Bulk 421 4.7.0 Email Senders Guidelines. d35si4791835qgf.4 - gsmtp (in reply to end of DATA command)

I can't think of anything else I can do to make this better.

Help! What else can I do?


Staff member

If this is a VPS, contact support (just fill out a new ticket) and ask to be placed through mailchannels smtp relay. We'll send the config needed to route the mail through and it will fix the issue.

2) option 2 is emailing to see why its being blocked. They do generally respond in ~1 week


New Member
Many times if the domain or SSL you are using does not match the server or something in postfix does not match the server popular mail clients will block them as spam. You can usually straighten it up by finding and fixing the issue and if necessary contacting the companies to ensure you are who you say you are (your server of course).