Wordpress and "You do not have sufficient permissions to access this page"

Quags

Administrator
Staff member
This one was quite annoying. An admin login was getting:
You do not have sufficient permissions to access this page

When trying to login to a page.


Here is the run down of possible fixes (there are many).

1) You lost your admin user permissions. Check in the mysql database for the admin user in wp_users. Now match that admin id in wp_usermeta

make sure wp_user_level is set to 10.

make sure wp_capabilities are a:1:{s:13:"administrator";b:1;}

Not it? 2)
Could be plugins. Temporarily disable plugins. Back up the current value and set

UPDATE wp_options SET option_value = 'a:0:{}' WHERE option_name = 'active_plugins';

Not it? 3) Force a db update

db_version in the wp_options, set this to a lower value. Log back into the wordpress admin section and rerun the database update.

#3 fixed it for me, I really think it should have been easier.
 
Thanks for the advice. I had this happen to me and it was because I lost my admin user privaledges. However, back then I didn't know about that so I ended up just losing the website because it was relatively new and I didn't see an effective way of getting it back.
 

AlexF15

New Member
Thanks for the information. I had this happen to me and I had no idea what to do after my admin was revoked. Thanks dude.
 

Quags

Administrator
Staff member
one more today

Code:
mysql> update hminsurance_usermeta set meta_key='hminsurance_capabilities' where meta_key='hmInsurance_capabilities' and user_id=1
  -> ;
Query OK, 1 row affected (0.00 sec)
Rows matched: 1  Changed: 1  Warnings: 0

mysql> update hminsurance_usermeta set meta_key='hminsurance_user_level' where meta_key='hmInsurance_user_level' and user_id=1
  -> ;
Query OK, 1 row affected (0.00 sec)
Rows matched: 1  Changed: 1  Warnings: 0
but in wp-config.php was $table_prefix = 'hminsurance_';

the capital I caused an issue
 
Thank you for this information. I had this happened to me quite a few times with my favourite site. I thought it was just a server problem, maybe there were too many clients at that time. I'm sure going to try these tips you've given us maybe they can remedy my problem.
 

kumkum

New Member
Hi,
I know this is old post but i want to share something which work for me.
You can resolve "You do not have sufficient permissions to access this page" wordpress error easily with few steps:

1. Fixing the Sufficient Permission Error
2. Edit the Prefixes using phpMyAdmin

  • Launch phpMyAdmin from the Database section
  • Select WordPress MySQL database. Or select the website mentioned in wp-config file with field “’DB_NAME’,’wpdb’”. This will open up all the tables in your database
  • The tables should be prefixed with wp_
  • From the list of tables, click on “wp_usermeta”
  • Find the “meta_key” column and change the prefixes from “wp_” to match those configured in your wp-config file:
  • wp_capabilities
  • wp_user_level
  • wp_user-settings
  • wp_user-settings-time
  • wp_dashboard_quick_press_last_post_id

database2.png


  • If you’ve got multiple users, you need to change the same for each user
3. Using MySQL commands

For the detailed information you can also check this link: https://hoststud.com/resources/reso...ficient-permissions-to-access-this-page”.660/
 
Top