Windows Hosting ASP and .Net Support

Outline of supported .Net Framework versions for Windows Web Hosting are available below. You can always change .Net the version you are using inside the Plesk control panel.

 

All ASP versions are supported including 

.NET 1, 1.0.1

.NET 2

.NET 3

.NET 3.5

.NET 4.5

.NET 4.6

.NET 4.7

.NET 5RC

.NET core 1.1

.Net Core 2.0

.Net Core 2.1.4

.Net Core 2.2.5

.Net Core 2.2.6

MVC Support

MVC 4

MVC 5

MVC 6

32 Comments

  1. Waqas September 23, 2016 at 2:11 am - Reply

    When do you plan to add support for .NET Core 1.0

    • Michael Lavrik September 23, 2016 at 6:35 pm - Reply

      It is now supported.

      • Zain Shaikh August 17, 2017 at 3:32 am - Reply

        How do I setup core 1.1 on the hosting? please provide any blog with steps and configuration?

  2. atilla October 5, 2016 at 7:02 am - Reply

    Do you support ASP.NET MVC 6?

  3. ST October 18, 2016 at 11:53 am - Reply

    Is ASP.NET Core 1.0.1 supported? How often do you update the support version? Thanks

    • John Quaglieri October 18, 2016 at 2:42 pm - Reply

      For windows shared hosting at interserver (running plesk ppa 11.5)

      ASP.NET Core 1.0 supported with Visual studio 2015

      • Stephen May 22, 2017 at 4:18 am - Reply

        Hi is ASP.NET Core 1.0.1 supported now as from 2017/05/22?

        • Jithin May 23, 2017 at 5:07 pm - Reply

          Yes ASP.NET core 1.0.4 & 1.1 supported on our servers.

  4. Oliver Leis October 19, 2016 at 3:20 pm - Reply

    The chat support wrote me only asp.net 4.6 is supported. No .net core.

    • Michael Lavrik October 19, 2016 at 4:02 pm - Reply

      I have checked with our admin and .net core 1.0 is now supported.

  5. Alex November 25, 2016 at 5:45 am - Reply

    Do you support Full Trust for ASP.NET?

  6. G August 3, 2017 at 7:31 am - Reply

    When will you support .net Core 1.1?

  7. Adam August 27, 2017 at 2:11 am - Reply

    When ASP.NET Core 2.0 will be supported?

    • Michael Lavrik August 27, 2017 at 4:31 pm - Reply

      we are now supporting .Net Core 2.0

      • Adam August 29, 2017 at 8:18 am - Reply

        that’s great news, thanks.

  8. Carlos June 29, 2019 at 3:28 pm - Reply

    When do you plan to support ASP.NET Core 2.2?

    • Michael Lavrik July 2, 2019 at 6:40 pm - Reply

      Already supported. Article updated. Thank You!

  9. Peter July 11, 2019 at 8:02 pm - Reply

    When will you add .NET framework 4.8.0?

    • Michael Lavrik July 12, 2019 at 12:12 pm - Reply

      Updated to 4.7.
      4.8 is not available yet no ETA.

  10. Yousuf Alsaiari July 30, 2019 at 4:51 pm - Reply

    hi sir,
    I am web developer and always need to test my customers websites, some of them are asp.net websites, others are php websites.
    Will I be able to test my customers websites if I get “ASP.net web hosting”?

    • Michael Lavrik July 30, 2019 at 4:58 pm - Reply

      Yes, it would make a great test environment.

      • Yousuf Alsaiari July 30, 2019 at 5:19 pm - Reply

        thanks sir,
        so I can test asp.net and php website in the “asp.net web hosting”, that is perfect for me.
        last question sir, I found the price for the “asp.net web hosting” is $5 per a year. Is the “Price Lock Guarantee” is included with this kind of web hosting?

  11. Reinaldo August 7, 2019 at 3:11 am - Reply

    Hello I have some questions:

    1- How can I configure paypal on my web site using your services?
    2- How can I deploy my own ASP.NET MVC 5 application in your servers?

    Thanks.

    • Michael Lavrik August 7, 2019 at 11:36 am - Reply

      Those questions can have many answers. When you work with your developer they will handle those issues for you.

  12. Muhammad August 27, 2019 at 2:19 am - Reply

    Hello. I am using .Net Web Api Core 2.2 but my database is Postgresql 10. My concern is that I do not see Postgre in your site. Do you guys have support for it?

    • Jithin August 27, 2019 at 6:34 am - Reply

      Hi Muhammad,

      We use Plesk control panel for our Windows Web Hosting. PostgreSQL is not currently supported in Plesk for Windows, as it supports MySQL and MSSQL instead.
      FYI: There are many online tools available for you to convert PostgreSQL databases into MySQL. Eg, pg2mysql

Leave A Comment